Home to Foleys Finest Audio

Lots of compile errors from Foleys GUI Magic Module in JUCE

Hi.

I get a huge amount of errors from files in the Foleys module when debugging my JUCE application. I’ve followed the instructions from this forum and GitHub. Anyone knows what seems to be the issue? I have got it working in a previous project. I updated JUCE to 6.0.4 and it might have caused issues (EDIT: I tried now with 6.0.3 and I still get lots of errors)

My JUCE settings for the module
bilde

Thanks for checking out PluginGuiMagic.

I am sorry, I have no idea what could lead to this. Our CI builds all examples before every release and I never seen such an error.

Could you please check, if the examples build on your machine?
You find them in the repository https://github.com/ffAudio/PluginGuiMagic

Please let me know if you could get this fixed.

Good luck

Turns out I must have changed JUCE Framework code by accident, causing a ripple effect of errors. My guess is an accidental replace-all. Did a re-install of JUCE and Foley, and I get no errors :slight_smile:

1 Like

Awesome news! Thanks for reporting back.

Copyright © 2020 Foleys Finest Audio UG. All rights reserved.